error: There was a problem with the editor 'vi'. 09.10.2017

Wer unter macOS mit git arbeitet ist vermutlich schon einmal über diesen Fehler gestolpert: error: There was a problem with the editor 'vi'.

Das Problem trat immer auf, wenn der Editor vi/vim verwendet wird z.B. bei merges bzw. --amend. Die Lösung dafür ist recht einfach:

 

git config --global core.editor /usr/bin/vim

 

Das war es dann auch schon. Das Problem war, dass der Editor vi beim schließen einen falschen exit code zurückgab, was für git scheinbar ein Problem darstellt. Die genaue Fehlerbeschreibung gibt es hier: http://tooky.co.uk/there-was-a-problem-with-the-editor-vi-git-on-mac-os-x/